Jump to content

Raspberry Pi als BTC / Lightning Full Node


 Share

Recommended Posts

vor 1 Stunde schrieb rasu:

weiss jmd, wie ich bei einer umbrel node die adresse, unter der jmd einen lightning kanal zu ihr eroeffnen kann, finde?

danke schonmal

Klicke links im Menü auf "Lightning".

Dann steht als Titel "Lightning-Network" und darüber muss ein grüner Punkt "running" stehen.

Gaaaanz rechts sind unscheinbare drei Punkte.

Ein Klick darauf zeigt dir "Lightning-Address". Kopiere dieses Monster von URL, darin ist deine Node-ID, deine Tor-Adresse und dein Port.

Das braucht dein Channelpartner um zu dir einen Channel zu eröffnen.

 

Der andere schiebt dann das Funding in den Channel und Ihr seid in der Lage Payments auszutauschen. Allerdings kannst du erstmal nur etwas empfangen. Sobald du etwas empfangen hast, kannst du das auch wieder zurück senden.  Oder du schließt den Channel wieder. Das kostet dann jedoch BTC-Gebühren, da das Öffnen und Schließen onchain erfolgt.

 

Teste mal aus - ich bin noch nicht soweit. 

  • Thanks 1
Link to comment
Share on other sites

vor einer Stunde schrieb Jokin:

Teste mal aus - ich bin noch nicht soweit. 

Ich bin auch noch nicht so weit. Nach Raspiblitz, MyNode jetzt mit Umbrel der dritte Node. Hatte mit Umbrel Anlaufschwierigkeiten, weil ich ein zu schwaches Netzteil für die verwendete Festplatte hatte. Bis ich das erkannt habe, hatte ich schon drei Installationen hinter mir 🙈🤣

Link to comment
Share on other sites

vor 1 Stunde schrieb kater:

Ich bin auch noch nicht so weit. Nach Raspiblitz, MyNode jetzt mit Umbrel der dritte Node. Hatte mit Umbrel Anlaufschwierigkeiten, weil ich ein zu schwaches Netzteil für die verwendete Festplatte hatte. Bis ich das erkannt habe, hatte ich schon drei Installationen hinter mir 🙈🤣

mit den anderen nicht zufrieden?

ich hab noch raspiblitz ausprobiert, aber ist mir zu kompliziert, ausserdem mit win 7 kein zugriff (kein ssh und kein scp....)

umbrel finde ich ganz schick und es gibt da ja jetzt auch viele apps, wobei ich mich durch die noch durchkaempfen muss...

Link to comment
Share on other sites

vor 51 Minuten schrieb rasu:

mit den anderen nicht zufrieden?

ich hab noch raspiblitz ausprobiert, aber ist mir zu kompliziert, ausserdem mit win 7 kein zugriff (kein ssh und kein scp....)

umbrel finde ich ganz schick und es gibt da ja jetzt auch viele apps, wobei ich mich durch die noch durchkaempfen muss...

Nein, ich teste die verschiedenen Nodes. Bisher am Stabilsten lief eindeutig immer der Raspiblitz. Bei MyNode hat sich irgendwann nach ein paar Updates die Blockchain nicht mehr synchronisiert. Zur Zeit läuft da die Sync. Interessant wird es für mich beim MyNode wenn das passiert ist und ich das Backup meiner Lightning Channel wieder herstelle. Mal sehen ob alles so funktioniert wie ich es mir erwarte... 

 

Btw. wundert mich dass du keinen ssh Zugriff auf den Blitz hast. Auch nicht mit dem Standardzugang? Oder könnte es an einer zu restriktiven FW scheitern? Evtl. einen Virenscanner der da Probleme macht?

 

Edited by kater
Link to comment
Share on other sites

nee, liegt an win 7,

mit win 10 vom laptop gehts...

 

meine probleme beim aufsetzen waren auch spannungsprobleme , als ich es mit ner 2,5 hdd probiert hab.

und als ich ne ssd genommen hab und das in der liste vom raspiblitz empfohlene kabel, dass das kabel mit windows zwar einwandfrei funktionierte, aber mit dem raspi nicht....

auch ein zweites, anders kabel ging nicht.

hab dann ein usb3 case fuer die ssd genommen, damit laeuft es jetzt stabil seit 1 woche

Link to comment
Share on other sites

vor einer Stunde schrieb rasu:

hab dann ein usb3 case fuer die ssd genommen, damit laeuft es jetzt stabil seit 1 woche

Ich hab ein Kabel mit eigener Stromversorgung.

Dafür hat dieses Kabel das Problem, dass es USB 3.0-Port das Wlan-Signal stört. Am USB 2.0-Port ist alles ok.

Beim Umbrel-Image erkennt er die SSD nicht am USB 2.0-Port, nur am 3.0-Port ... Oh, man.

 

Beim Ubrel hab ich die Installation noch nicht begriffen. Offenbar werden die Wallet- und Channel-Backups verschlüsselt auf einem zentralen Server abgelegt. Das kann man wohl auch nicht ändern? Somit braucht es stets diesen zentralen Backup-Server?

Wer kennt sich aus?

Ansonsten ist der ganz nett. Mit seiner eigenen Cloud (Nextcloud-App) ist der auch als Fileserver im lokalen Netz brauchbar. Aber auch hier braucht es ein Backup-Konzept, das man sich selbst erstellen muss.

Link to comment
Share on other sites

vor 8 Stunden schrieb Jokin:

Ich hab ein Kabel mit eigener Stromversorgung.

Dafür hat dieses Kabel das Problem, dass es USB 3.0-Port das Wlan-Signal stört. Am USB 2.0-Port ist alles ok.

Beim Umbrel-Image erkennt er die SSD nicht am USB 2.0-Port, nur am 3.0-Port ... Oh, man.

 

Beim Ubrel hab ich die Installation noch nicht begriffen. Offenbar werden die Wallet- und Channel-Backups verschlüsselt auf einem zentralen Server abgelegt. Das kann man wohl auch nicht ändern? Somit braucht es stets diesen zentralen Backup-Server?

Wer kennt sich aus?

Ansonsten ist der ganz nett. Mit seiner eigenen Cloud (Nextcloud-App) ist der auch als Fileserver im lokalen Netz brauchbar. Aber auch hier braucht es ein Backup-Konzept, das man sich selbst erstellen muss.

Ich kenne das Problem des USB 3 Ports mit der Störung des Wlan hauptsächlich von der Fritzbox. Beim Raspi gibt's das Problem auch? Interessant! Wenn du die Möglichkeit hast, teste doch mal die Verbindung ausschließlich mit dem 5 Ghz Wlan...

vor 10 Stunden schrieb rasu:

nee, liegt an win 7,

mit win 10 vom laptop gehts...

 

meine probleme beim aufsetzen waren auch spannungsprobleme , als ich es mit ner 2,5 hdd probiert hab.

und als ich ne ssd genommen hab und das in der liste vom raspiblitz empfohlene kabel, dass das kabel mit windows zwar einwandfrei funktionierte, aber mit dem raspi nicht....

auch ein zweites, anders kabel ging nicht.

hab dann ein usb3 case fuer die ssd genommen, damit laeuft es jetzt stabil seit 1 woche

Was die Spannungsprobleme mit einer externen USB Festplatte betrifft, habe ich von einem 5V,3A, 15 W Netzteil zu einem 5V,3,5A, 17 W Netzteil gewechselt. 

Mit 

vcgencmd get_throttled

einmal geprüft ob es noch eine Unterspannung gibt. Wenn der Raspi:

throttled=0x0

ausspuckt, ist die Spannung in Ordnung.

Link to comment
Share on other sites

vor 41 Minuten schrieb kater:

Ich kenne das Problem des USB 3 Ports mit der Störung des Wlan hauptsächlich von der Fritzbox. Beim Raspi gibt's das Problem auch? Interessant! Wenn du die Möglichkeit hast, teste doch mal die Verbindung ausschließlich mit dem 5 Ghz Wlan...

Hab heute mal bisschen dazu gegooglet. Das ist ein konzeptionelles Problem. Hat man den USB-3-Port zu dicht an WLAN-Antennen, dann gibt's Probleme im 2,4 GHz-Band.

Ich hab das eigentlich flexibel eingestellt, muss nochmal schauen wieso das nicht so richtig klappt.

 

  • Like 1
Link to comment
Share on other sites

vor 38 Minuten schrieb Jokin:

Hab heute mal bisschen dazu gegooglet. Das ist ein konzeptionelles Problem. Hat man den USB-3-Port zu dicht an WLAN-Antennen, dann gibt's Probleme im 2,4 GHz-Band.

Ich hab das eigentlich flexibel eingestellt, muss nochmal schauen wieso das nicht so richtig klappt.

 

Wenn du willst dass der Raspi nur auf 5 Ghz connected müsstest du die SSID an deinen Router entsprechend trennen. Eine für 2,4 Ghz, eine für 5 Ghz. Ich finde diese "Lösung" aber mit Blick auf andere Gerät in deinem Netzwerk mehr als schlecht, das du diesen die Möglichkeit nimmst zwischen den Kanälen zu wechseln. Am Besten ist LAN. Wenn du das bei dir nicht umsetzen kannst, kannst du das vielleicht auch über Powerlan lösen? In so einem Fall heiligt bekanntlich der Zweck die Mittel ;)

Link to comment
Share on other sites

Neee, das ist ungefähr so:

Fritzbox und Raspis hängen alle am Gigabit-LAN-Switch.

WLAN brauchen lediglich die mobilen Geräte. 

Da ich demnächst eh auch eine aktuelle Fritzbox aufrüste werde ich wohl alle anderen Geräte auf das 5 GHz-Band zwingen. Das letzte verbliebene Windowsnotebook muss dann mal weg. Dazu brauche ich aber ein anderes Gerät weil eine ganz bestimmte Software nicht für MacOs verfügbar ist. Und 80 Euro für Parallels auszugeben ... nee, da bin ich auch etwas zu geizig, das isses mir nicht wert :D

Link to comment
Share on other sites

  • 4 weeks later...

Oh Wahnsinn! Am 19.12 einen Raspi 4B 4GB bestellt. Heute nachgefragt -> Bestätigung kann erst für den 15. Juni gegeben werden! Chipmangel! Bin unschlüssig, ob ich warte oder den Raspi völlig überteuert irgendwo kaufe. Die Dame am Telefon meinte, dass es auch schon deutlich früher wieder welche geben kann.

Ist bei mir ein langer Weg zur Fullnode 🙂

Link to comment
Share on other sites

So schreibe hier auch ,mal

.ich habe nun seit 1 Jahr meinen eigenen Fullnode auf einem Raspi4 8GB laufen mit myNode.

Ich bin da nach dieser Anleitung vorgegangen...

https://cryptotant.de/bitcoin-full-node-bauen/

ich fand es selbst für mich einfach und läuft bis jetzt ohne Probleme....auch die Updateanleitung dort hatte ich hinbekommen(mittlerweile habe ich die myNode Premium)

Was mache ich mit meinem Node...nachdem ich auch den electrum server und rtl aktiviert hatte.

1.Ich habe meinen Ledger mit meinem Electrum wallet verbunden und dieses mit meinem Node.....siehe hier

https://mynodebtc.github.io/electrum/electrum.html

2.Ein Ligtning Wallet erstellt....siehe hier

https://mynodebtc.github.io/lightning/create.html

3.Ride the Lightning (RTL) aktiviert...siehe hier

https://mynodebtc.github.io/lightning/rtl.html

Und wie ich es benutze.....siehe hier

https://coincharge.io/ride-the-lightning/

4..Da ich myNode Premium habe kann ich jetzt jederzeit über den Torbrowser(wenn ich will auch per vpn) mit meiner onion addy von überall auf meinen Node und das Dashbord zugreifen....

und somit auch auf rtl ....

5.Die Familie weiter weg startet nun den Torbrowser und Ihr Electrum Wallet das als ein server mit meinem Node per onion addy verbunden ist......funktioniert---siehe

https://mynodebtc.github.io/tor/electrum.html

 

Fazit:

Das Netzwerk zu unterstützen macht mir Spass und es gibt manche Vorteile...kann alle Abfragen zu Mempool od. blockexplorer über meinen Node machen und brauche keinen anderen...und ich lob myNode nicht in den Himmel...aber für mich funktionierts.....

 

 

 

  • Thanks 3
  • Like 1
Link to comment
Share on other sites

vor 9 Stunden schrieb 8SAMK3I7:

Oh Wahnsinn! Am 19.12 einen Raspi 4B 4GB bestellt. Heute nachgefragt -> Bestätigung kann erst für den 15. Juni gegeben werden! Chipmangel! Bin unschlüssig, ob ich warte oder den Raspi völlig überteuert irgendwo kaufe. Die Dame am Telefon meinte, dass es auch schon deutlich früher wieder welche geben kann.

Ist bei mir ein langer Weg zur Fullnode 🙂

Schau' mal bei Armboard.de, ob die nicht schneller zu noch halbwegs vertretbarem Preis tatsächlich liefern können. Ich hab' da Ende November noch einen RPi 4 8GB RAM für unter 100€ bekommen, wo andere weit mehr als 25% Aufschlag aufgerufen haben (und trotzdem nicht liefern konnten oder wollten).

Tante Edit meint: auch da leider vergriffen, sorry!
Lieferbar sind aber anscheinend der Raspberry Pi 400, ~70€

Edited by Cricktor
  • Thanks 1
Link to comment
Share on other sites

vor 14 Stunden schrieb Cricktor:

Schau' mal bei Armboard.de, ob die nicht schneller zu noch halbwegs vertretbarem Preis tatsächlich liefern können. Ich hab' da Ende November noch einen RPi 4 8GB RAM für unter 100€ bekommen, wo andere weit mehr als 25% Aufschlag aufgerufen haben (und trotzdem nicht liefern konnten oder wollten).

Tante Edit meint: auch da leider vergriffen, sorry!
Lieferbar sind aber anscheinend der Raspberry Pi 400, ~70€

Eine gute Idee - darin ist ebenfalls ein Raspi 4 mit 4GB verbaut. Dummerweise hat die Platine völlig andere Maße. Das schau ich mir nochmal genauer an. Besten Dank für den Tipp!

Link to comment
Share on other sites

Ja, klar, der Formfaktor ist gänzlich anders, aber was willste machen, wenn die Liefersituation so beknackt ist, wie aktuell. Ich sehe auch nicht ein, deutlich überhöhte Preise von "Scalpern" zu bezahlen, die die Raspi-Knappheit ausnutzen. Angebot und Nachfrage, schon klar, aber ich ziehe trotzdem Grenzen.

Aber wenn du einfach eine Raspi-Node austesten möchtest und kein kleines Display mit in ein schnuckeliges Gehäuse verbauen möchtest, geht auch ein Raspi 400. Den finde ich übrigens ganz nett, leider für mich nicht mit 8GB RAM zu bekommen, wenn ich das richtig gesehen habe.

Habe zwei Raspis und brauche hoffentlich vorerst keinen dritten. Irgendwann kommt auch ein Raspi 5...

Edited by Cricktor
Link to comment
Share on other sites

vor 19 Minuten schrieb Cricktor:

Ja, klar, der Formfaktor ist gänzlich anders, aber was willste machen, wenn die Liefersituation so beknackt ist, wie aktuell. Ich sehe auch nicht ein, deutlich überhöhte Preise von "Scalpern" zu bezahlen, die die Raspi-Knappheit ausnutzen. Angebot und Nachfrage, schon klar, aber ich ziehe trotzdem Grenzen.

Aber wenn du einfach eine Raspi-Node austesten möchtest und kein kleines Display mit in ein schnuckeliges Gehäuse verbauen möchtest, geht auch ein Raspi 400. Den finde ich übrigens ganz nett, leider für mich nicht mit 8GB RAM zu bekommen, wenn ich das richtig gesehen habe.

Habe zwei Raspis und brauche hoffentlich vorerst keinen dritten. Irgendwann kommt auch ein Raspi 5...

Habe schon ein Glasgefäß und möcht da was Schönes basteln. Da passt das aus dem Pi400 leider nicht. Hatte gerade bei Kleinanzeigen beinahe Glück. Werde ich so weiter versuchen. Oder der Raspi ist irgendwann wieder lieferbar.

Anderes Thema - wie handhabt ihr das eigentlich - über Tor verbinden oder nicht? Ständig Tor-Verbindungen können doch auch komisch sein, oder? Offen sichtbar ist doch nicht wirklich kritisch. Tendiere derzeit ohne Tor die Node zu betreiben. Was meint ihr?

Link to comment
Share on other sites

Für Verbindungen von außen habe ich bei meiner Raspiblitz-Node TOR aktiv, ist mir lieber so. Im lokalen Netzwerk funktioniert es ja auch ohne TOR, das reicht mir für meine Anwendungszwecke so aus.

  • Thanks 1
Link to comment
Share on other sites

vor 5 Minuten schrieb 8SAMK3I7:

Habe schon ein Glasgefäß und möcht da was Schönes basteln. Da passt das aus dem Pi400 leider nicht. Hatte gerade bei Kleinanzeigen beinahe Glück. Werde ich so weiter versuchen. Oder der Raspi ist irgendwann wieder lieferbar.

Anderes Thema - wie handhabt ihr das eigentlich - über Tor verbinden oder nicht? Ständig Tor-Verbindungen können doch auch komisch sein, oder? Offen sichtbar ist doch nicht wirklich kritisch. Tendiere derzeit ohne Tor die Node zu betreiben. Was meint ihr?

taeglicher ip-wechsel ist das problem ohne tor.

ueberlege derzeit, ein tor-relay zu betreiben, da sieht niemand die strecke bis zum tor-netzwerk 😉

  • Thanks 1
Link to comment
Share on other sites

Moin, moin liebe Kryptoianer. 

Ich hab ein Problem. Ich bin aktuell dabei eine BTC Node per Umbrel aufzusetzen. Raspberry Pi 4, SSD usw. usf. alles vorhanden. Zu Anfang habe ich die SSD direkt am PI angeschlossen, bis ich gemerkt habe das die SSD keine Spannung hat. Also recherchiert und rausgefunden, dass man dies doch mit einem USB Hub + Power Supply lösen könnte. Gesagt getan. Alles wie gehabt, bis auf die SSD die jetzt über den Hub läuft. 

Mein Problem ist, dass ich Umbrel einfach nicht zum laufen bekomme, da er mir folgenden Fehler (egal ob direkt am Pi oder per Hub angeschlossen) ausspuckt:

"Error: No external drive found"

Irgendwelche Ideen was das sein könnte? Dazu möchte ich sagen, dass ich die Micro-SD schon zig male formatiert habe und immer wieder neu aufgesetzt habe. Im Bild seht ihr meine Fehlermeldung.

https://ibb.co/dJZDk7P

LG

c to oincierge

Link to comment
Share on other sites

vor 15 Minuten schrieb coincierge:

Error: No external drive found

Den Fehler habe ich auch wenn ich die USB-3.0-SSD an einen schwarzen USB-Port anschließe.

Am blauen geht's.

Das nächste Problem werden WLAN-Probleme sein, denn USB-3.0 interferriert mit dem 2,4 GHz-Band.

Das Einpacken der Verbindung in Alufolie und Kontakt zum Metallschirm des USB-Ports verbessert die Situation.

  • Thanks 1
Link to comment
Share on other sites

vor 2 Minuten schrieb Jokin:

Den Fehler habe ich auch wenn ich die USB-3.0-SSD an einen schwarzen USB-Port anschließe.

Am blauen geht's.

Das nächste Problem werden WLAN-Probleme sein, denn USB-3.0 interferriert mit dem 2,4 GHz-Band.

Das Einpacken der Verbindung in Alufolie und Kontakt zum Metallschirm des USB-Ports verbessert die Situation.

Ich habe einen Serverraum bei mir im Haus und da habe ich die Node direkt am Router angeschlossen, so dass ich kein WLAN nutze. Die SSD läuft am 3.0 (blauen) Port.

Langsam bin ich ratlos, weil ich mich darauf total gefreut habe es endlich mal durchzuziehen. Nun funktioniert es nicht.

Link to comment
Share on other sites

vor 27 Minuten schrieb coincierge:

Ich habe einen Serverraum bei mir im Haus und da habe ich die Node direkt am Router angeschlossen, so dass ich kein WLAN nutze. Die SSD läuft am 3.0 (blauen) Port.

Langsam bin ich ratlos, weil ich mich darauf total gefreut habe es endlich mal durchzuziehen. Nun funktioniert es nicht.

Ist die SSD ext4-formatiert?

Kannst du die SSD mit einem anderen Image, z.B. Raspbian nutzen?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.