Jump to content

Raspberry Pi als BTC / Lightning Full Node


 Share

Recommended Posts

vor 10 Minuten schrieb Jokin:

Ist die SSD ext4-formatiert?

Kannst du die SSD mit einem anderen Image, z.B. Raspbian nutzen?

ICh habe es mit NTFS und ExFat probiert. Mit ext4 tatsächlich noch nicht. Ich probiere es mal sofort aus.

Link to comment
Share on other sites

vor 8 Stunden schrieb coincierge:

Moin, moin liebe Kryptoianer. 

Ich hab ein Problem. Ich bin aktuell dabei eine BTC Node per Umbrel aufzusetzen. Raspberry Pi 4, SSD usw. usf. alles vorhanden. Zu Anfang habe ich die SSD direkt am PI angeschlossen, bis ich gemerkt habe das die SSD keine Spannung hat. Also recherchiert und rausgefunden, dass man dies doch mit einem USB Hub + Power Supply lösen könnte. Gesagt getan. Alles wie gehabt, bis auf die SSD die jetzt über den Hub läuft. 

Mein Problem ist, dass ich Umbrel einfach nicht zum laufen bekomme, da er mir folgenden Fehler (egal ob direkt am Pi oder per Hub angeschlossen) ausspuckt:

"Error: No external drive found"

Irgendwelche Ideen was das sein könnte? Dazu möchte ich sagen, dass ich die Micro-SD schon zig male formatiert habe und immer wieder neu aufgesetzt habe. Im Bild seht ihr meine Fehlermeldung.

https://ibb.co/dJZDk7P

LG

c to oincierge

nicht alle sata-usb adapter funktionieren mit dem raspi, ich hatte auch das kabel, welches in der anleitung auf github verlinkt ist zuerst versucht, ohne erfolg.

am win rechner fuzte das kabel uebrigens....

hab dann ein case gekauft, wo ich die ssd einlegen konnte, aussen hat das die gleiche steckbuchse wie eine externe hdd, usb3, hersteller logilink, 12€

damit gehts

edit:

https://www.omega24.shop/products/hdd-gehause-2-5-sata-usb3-1?_pos=2&_sid=f3a223d34&_ss=r

Edited by rasu
.
Link to comment
Share on other sites

Moin

komische Sache.. Irgendetwas ist faul/defekt. Der normale Weg in deinem Fall ist die SD Karte zum Einrichten zu benutzen und später ausschließlich mit dem externen Speicher zu arbeiten.

Was sagt denn journalctl und lsusb nachdem du deine USB Disk ansteckst? Den meisten Stress macht die Stromversorgung. Du solltest alle Netzteile prüfen ggf anderes verwenden. Schick uns doch einmal die logs..

Link to comment
Share on other sites

Wenn du einen powered USB-Hub nutzt, sollte die SSD keine Probleme machen, vorausgesetzt der USB-Adapter zickt nicht rum (manche brauchen "Quirks"-Einträge) ansonsten muss man schon etwas aufpassen, weil der Raspi 4B nur ca. 1,2A in Summe (!) für alle angeschlossenen USB-Geräte bereit stellen kann. Manche SSD-Marken sind stromhungriger als andere.

Muss der SSD-Datenträger bei der Einrichtung von Umbrel überhaupt initialisiert sein?

Original Raspi-Netzteil? Andere gehen auch, aber nur wenn die bombensicher mindestens 15 Watt und stabile 5-5,1V liefern können, ohne Wenn und Aber.

Edited by Cricktor
  • Like 1
Link to comment
Share on other sites

Am 14.1.2022 um 16:26 schrieb rasu:

nicht alle sata-usb adapter funktionieren mit dem raspi, ich hatte auch das kabel, welches in der anleitung auf github verlinkt ist zuerst versucht, ohne erfolg.

am win rechner fuzte das kabel uebrigens....

hab dann ein case gekauft, wo ich die ssd einlegen konnte, aussen hat das die gleiche steckbuchse wie eine externe hdd, usb3, hersteller logilink, 12€

damit gehts

edit:

https://www.omega24.shop/products/hdd-gehause-2-5-sata-usb3-1?_pos=2&_sid=f3a223d34&_ss=r

Danke für den Tipp. Ich denke es liegt am Adapter. Alles funktioniert einwandfrei. Vom Raspi bis hin zur SSD am Desktop. Ich habe vorsorglich mal einen neuen bestellt. Sollte morgen eintreffen. Ach, was ist das ärgerlich.

Am 14.1.2022 um 17:25 schrieb RGarbach:

Moin

komische Sache.. Irgendetwas ist faul/defekt. Der normale Weg in deinem Fall ist die SD Karte zum Einrichten zu benutzen und später ausschließlich mit dem externen Speicher zu arbeiten.

Was sagt denn journalctl und lsusb nachdem du deine USB Disk ansteckst? Den meisten Stress macht die Stromversorgung. Du solltest alle Netzteile prüfen ggf anderes verwenden. Schick uns doch einmal die logs..

Die Stromversorgung habe ich durch einen aktiven USB Hub gelöst. Die SSD wird nicht mit Strom vom Raspi versorgt. Journalalctl und Isusb lasse ich später die SSD auslesen.

Am 14.1.2022 um 18:02 schrieb Cricktor:

Wenn du einen powered USB-Hub nutzt, sollte die SSD keine Probleme machen, vorausgesetzt der USB-Adapter zickt nicht rum (manche brauchen "Quirks"-Einträge) ansonsten muss man schon etwas aufpassen, weil der Raspi 4B nur ca. 1,2A in Summe (!) für alle angeschlossenen USB-Geräte bereit stellen kann. Manche SSD-Marken sind stromhungriger als andere.

Muss der SSD-Datenträger bei der Einrichtung von Umbrel überhaupt initialisiert sein?

Original Raspi-Netzteil? Andere gehen auch, aber nur wenn die bombensicher mindestens 15 Watt und stabile 5-5,1V liefern können, ohne Wenn und Aber.

Ich war der Meinung das die SSD vorher nicht initialisiert wird. Ich denke ich habe einfach "vorgesorgt" und den Datenträger auf Ext4 formatiert.

Aber nada, nichts. 

Wie gesagt ein wenig ärgerlich, dass es an einem Adapter scheitern soll. 

Link to comment
Share on other sites

vor 33 Minuten schrieb coincierge:

 

Wie gesagt ein wenig ärgerlich, dass es an einem Adapter scheitern soll. 

hat mich auch etwa 2 tage gekostet....

 

Link to comment
Share on other sites

So ich habe kein Bock mehr. 
 

- Zwei neue SSD Adapter gekauft, funktionieren nicht, selber Fehler

- SSD mit zusätzlichem Powerplug am laufen

- Neue SD Karten gekauft, funktioniert immer noch nicht

- Festplatte mit Ext4 formatiert, funktioniert immer noch nicht

- Mindestens 30x das System neu aufgesetzt

Langsam platzt mir der Geduldsfaden, ernsthaft.

Hätte auch direkt bei Umbrel kaufen können. 
 

 

 

Link to comment
Share on other sites

mal spasseshalber mit ner 2,5" hdd probiert? (die braucht aber viel strom)

dann weisst du  obs an ssd/adapter oder raspi liegt.

den gleichen adapter gekauft, den ich hab oder nen anderen? kabel oder case?

hab auch 2 kabel probiert, die nicht gingen, am win rechner aber wohl.

da ist noch irgendeine elektronik drin, oder eben nicht...

Link to comment
Share on other sites

Am 14.1.2022 um 14:46 schrieb coincierge:

Moin, moin liebe Kryptoianer. 

Ich hab ein Problem. Ich bin aktuell dabei eine BTC Node per Umbrel aufzusetzen. Raspberry Pi 4, SSD usw. usf. alles vorhanden. Zu Anfang habe ich die SSD direkt am PI angeschlossen, bis ich gemerkt habe das die SSD keine Spannung hat. Also recherchiert und rausgefunden, dass man dies doch mit einem USB Hub + Power Supply lösen könnte. Gesagt getan. Alles wie gehabt, bis auf die SSD die jetzt über den Hub läuft. 

Mein Problem ist, dass ich Umbrel einfach nicht zum laufen bekomme, da er mir folgenden Fehler (egal ob direkt am Pi oder per Hub angeschlossen) ausspuckt:

"Error: No external drive found"

Irgendwelche Ideen was das sein könnte? Dazu möchte ich sagen, dass ich die Micro-SD schon zig male formatiert habe und immer wieder neu aufgesetzt habe. Im Bild seht ihr meine Fehlermeldung.

https://ibb.co/dJZDk7P

LG

c to oincierge

 

vor 9 Stunden schrieb coincierge:

So ich habe kein Bock mehr. 
 

- Zwei neue SSD Adapter gekauft, funktionieren nicht, selber Fehler

- SSD mit zusätzlichem Powerplug am laufen

- Neue SD Karten gekauft, funktioniert immer noch nicht

- Festplatte mit Ext4 formatiert, funktioniert immer noch nicht

- Mindestens 30x das System neu aufgesetzt

Langsam platzt mir der Geduldsfaden, ernsthaft.

Hätte auch direkt bei Umbrel kaufen können. 
 

Oh weia - das ist ja wirklich langsam richtig schlimm. Hab mich vorhin hingesetzt und einen Raspiblitz aufgesetzt. Hab schon mit dem Schlimmsten gerechnet. Zusätzliche Netzteile bereit gehabt usw. Tatsächlich reicht mir ein 5,1V / 3A Netzteil um den Raspi, ein 3,5" Display und eine USB-SSD-Festplatte zu betreiben. Alles lief reibungslos und hat schon 5% der Blockchain geladen. Obwohl meine SSD-Platte im Datenblatt 1,5A angibt und der Raspi eigentlich nur 1,1A insgesamt unterstützt.

Wenn es nicht Umbrel sein muss, teste doch mal den Raspiblitz:

https://raspiblitz.org/

Ansonsten auf jeden Fall mal, wie weiter oben von @RGarbach angegeben, den Befehl lsusb verwenden. Damit siehst du, ob deine Platte überhaupt erkannt wird. Drücke Dir die Daumen, dass deine Geduld und Hartnäckigkeit bald belohnt wird!

Link to comment
Share on other sites

vor 30 Minuten schrieb 8SAMK3I7:

Ansonsten auf jeden Fall mal, wie weiter oben von @RGarbach angegeben, den Befehl lsusb verwenden. Damit siehst du, ob deine Platte überhaupt erkannt wird. Drücke Dir die Daumen, dass deine Geduld und Hartnäckigkeit bald belohnt wird!

Du wirst es kaum glauben. Ich war vorhin noch mal bei Saturn und habe mir eine neue 1TB SSD gekauf. Soviel TB hatte ich noch nie zu Hause! Und du wirst es kaum glauben......es funktioniert immer noch nicht. Nun habe ich mir das hier bestellt. Wenn das nicht funktioniert. IDGAF#umbrel

Link to comment
Share on other sites

vor 5 Minuten schrieb CfPost:

beim Raspi zumindest beim 4er gibt es eine eine Einstellung, dass mehr Strom an den USB- Anschlüssen verfügbar ist. Bei mir läufts (1TB an USB3).

Verträgt auch gleichzeitig Funktastatur und Uralt-Bildschirm und HDMI-Adapter (der Micro-HDMIAnschluss mit 5m Kabel) alles kein Problem .

 

(klar, die 1. SSD habe ich wieder zurück gegeben, lag möglicherweise am Strom, die Einstellung habe ich erst später entdeckt)

 

 

 

Wie kann ich dies ändern?

Link to comment
Share on other sites

ich denke, das ist in dem image von umbrel schon so eingestellt, geht bei mir einwandfrei, die ssd zu betreiben, ohne irgendwas extra einzustellen oder extra stromversorgung.

das case wird die loesung sein....

Link to comment
Share on other sites

vor 41 Minuten schrieb coincierge:

Du wirst es kaum glauben. Ich war vorhin noch mal bei Saturn und habe mir eine neue 1TB SSD gekauf. Soviel TB hatte ich noch nie zu Hause! Und du wirst es kaum glauben......es funktioniert immer noch nicht. Nun habe ich mir das hier bestellt. Wenn das nicht funktioniert. IDGAF#umbrel

Oh man - das kenne ich. Neuer Versuch voller Hoffnung ... und...Zack, nein, wieder nix. Das ist zermürbend. Auch spannend, wieviele "FehlerSuchMöglichkeiten" es gibt. Jedoch wird das Dranbleiben zum Gelingen führen. Umwege erhöhen die Ortskenntnis und die Freude beim Gelingen ist herrlich.

vor 4 Minuten schrieb rasu:

ich denke, das ist in dem image von umbrel schon so eingestellt, geht bei mir einwandfrei, die ssd zu betreiben, ohne irgendwas extra einzustellen oder extra stromversorgung.

das case wird die loesung sein....

So stehts geschrieben und wird gelingen!

Link to comment
Share on other sites

Ich habe für meine Raspiblitz-Node die Hardware-Vorschläge von Raspiblitz befolgt und keinerlei Probleme damit gehabt (ohne Display aufgebaut). Hat aus dem Stand funktioniert.

(Kopiert aus dem Github-Repo von Raspiblitz, ich hab' die Amazon-Referrals mal drin gelassen, da es bestimmt nicht schadet, wenn die Raspiblitz-Macher ein wenig davon profitieren.)

Das Blöde ist, daß man sich bei der Hardware nicht immer vollkommen sicher sein kann, daß die interne Elektronik sich nicht ändert und andere Interface-Chips verbaut werden, ohne daß dies irgendwie angekündigt oder dokumentiert wäre. Zur Not habe ich aber auch noch ein paar andere USB3-Gehäuse, die alle irgendwelche anderen IDs mit lsusb ausspucken, aber größtenteils am Raspi4B funktionieren (nicht extensiv getestet allerdings, sondern nur ob sie generell gehen und einigermaßen schnell arbeiten).

Samsung 860 (ggf. auch die 870) EVO SSDs (die QLC-Dinger nehme ich nicht) sind meist auch recht genügsam beim Strombedarf, obwohl die 860 EVO auf dem Aufkleber einen Strombedarf von 1,2A ausweist, während andere durchaus kräftiger zulangen. In meiner Raspiblitz-Node läuft die Sandisk Plus, die auch oben verlinkt ist. Ob eine Raspi-Node mit einer Samsung 860 EVO läuft, werde ich demnächst mal antesten.

Bei den Netzteilen für den Raspi heisst es auch aufzupassen. Das erste Original-Netzteil kam normal in der Pappschachtel und funktioniert seitdem tadellos. Dann habe ich denselben Artikel bei Amazon nachbestellt und es kam ein äußerlich original aussehendes Raspi4-Netzteil in einer durchsichtigen Plastiktüte an: dead-on-arrival, mein zweiter Raspi tat damit keinen Mucks, ein anderes USB-C-Gerät auch nicht. Und dann war das zweite nachbestellte Netzteil auch relativ teuer, na schönen Dank auch, wieso ich es im trüben Fluss dann doch bestellt hab, weiß ich jetzt auch nicht mehr (Amazon Prime versaut einen weil die Versandkosten wegfallen, mea culpa). Retoure ist unterwegs.

Naja, dann mal originale Raspi4-Netzteile bei berrybase.de bestellt, die kamen an, wie sie aussehen sollten und funktionieren wenigstens auch.

Nächstes kleines Projekt: ein BTC-Candlestick-Ticker mit 'nem Raspi Zero und kleinem ePaper-Display (etwas selbe Größe wie der Raspi Zero).

  • Love it 1
  • Like 2
Link to comment
Share on other sites

vor 7 Stunden schrieb Cricktor:

Ich habe für meine Raspiblitz-Node die Hardware-Vorschläge von Raspiblitz befolgt und keinerlei Probleme damit gehabt (ohne Display aufgebaut). Hat aus dem Stand funktioniert.

Raspiblitz hat bei mir auch aus dem Stand funktioniert. Dabei hab ich von Hardwarevorschlägen nur Größenvorgaben beachtet. Mit Display.

 

vor 7 Stunden schrieb Cricktor:

Samsung 860 (ggf. auch die 870) EVO SSDs (die QLC-Dinger nehme ich nicht) sind meist auch recht genügsam beim Strombedarf, obwohl die 860 EVO auf dem Aufkleber einen Strombedarf von 1,2A ausweist, während andere durchaus kräftiger zulangen. In meiner Raspiblitz-Node läuft die Sandisk Plus, die auch oben verlinkt ist. Ob eine Raspi-Node mit einer Samsung 860 EVO läuft, werde ich demnächst mal antesten.

Habe die Samsung Portable T7 (ohne Touch). 5V / 1,5A. Ohne externe Stromquelle nur am USB-Port vom Raspi. Sollte eigentlich nicht funktionieren und wollte mir nur anschauen, wie so ein Ausfall abläuft. Sehr kurzes USB-Kabel (10cm). Läuft seit über 12h ohne Probleme. Sync ist bei über 40%. Warte dennoch auf einen Ausfall. 12h sind ja noch garnix. Wenn Sync durch ist werde ich auch mal messen, wieviel Strom tatsächlich gezogen wird.

Sehr interessant wie unterschiedlich das abläuft. Wenn Zwei das Selbe tun ist es noch lange nicht das Gleiche.

Link to comment
Share on other sites

So, heute habe ich das Orican Case erhalten. Es funktioniert nicht. Es funktioniert einfach nicht.

Ich bin raus aus diesem Projekt, da ich einfach keine Lösungen mehr habe. Sorry, aber was für ein Müll! Ich versuch es morgen mit einem Raspiblitz. Umbrel ist durch bei mir!

  • Sad 1
Link to comment
Share on other sites

wenn du eine normale usb3 2,5" hdd hast, probiers mal versuchshalber.

was bei mir auch ein mal passiert ist, dass ich es geschafft habe, den usb stecker verkehrt herum in dem raspi zu stecken, weil ich das kabel so schoen klein aufgeringelt zusammengebunden habe, dass da viel spannung drauf war....  😉

Link to comment
Share on other sites

Vielleicht nicht das Schlimmste, daß Umbrel bei dir Probleme macht. Ich bin kein Experte, aber sicherheitstechnisch erscheint mir Umbrel etwas fragwürdig. Letztens gab's doch so'n Emergency-Fix bei denen, weil Leuten die Lightning-Wallets geplündert wurden. So wie ich das verstanden habe, passierte das, nicht weil die Lightning-Wallet ein Sicherheitsproblem hatte, sondern weil das Umbrel-Setup mit Standard-Passwörtern arbeitet, um das vor dem Benutzer zu verbergen (Passwortabfragen).

Da Umbrel fast alle Services der Container (oder so ähnlich, erinnere mich nicht an alle Details; wurde hier im Forum auch irgendwo gemeldet) nach außen "exposed" hatte, war es wohl nur eine Frage der Zeit, bis ihnen dieses "benutzerfreundliche" Sicherheitsdesign auf die Füße fällt.

Bestimmt beschreibe ich das Problem des Umbrel-Sicherheitsdesigns nicht ganz korrekt, aber ich bleibe lieber bei Raspiblitz, test höchstens mal ohne beladene Wallet bei Gelegenheit Umbrel "just for fun".

  • Thanks 2
  • Like 2
Link to comment
Share on other sites

vor 4 Stunden schrieb coincierge:

So, heute habe ich das Orican Case erhalten. Es funktioniert nicht. Es funktioniert einfach nicht.

Ich bin raus aus diesem Projekt, da ich einfach keine Lösungen mehr habe. Sorry, aber was für ein Müll! Ich versuch es morgen mit einem Raspiblitz. Umbrel ist durch bei mir!

Liegt das dann am Raspi selber? Hast da mal ein Bios-Update gemacht? Ansonsten viel Erfolg mit dem Raspiblitz. Diese Anleitung habe ich verwendet:

https://raspiblitz.org/

Link to comment
Share on other sites

So, da mir der Mist keine Ruhe gelassen hat, habe ich ein alten ausrangierten Intel NUC mit Linux (Ubuntu) bespielt und dort per Terminal mir die Umbrel Node aufgesetzt. Jetzt funktioniert Umbrel und der Blockchain-Sync läuft aktuell. 

19V, 3,42mA = 65 Watt/h = ca. 170€/p.a. Stromkosten--> ist halt so!

Raspi funktioniert nicht. Da muss ein Defekt vorliegen welchen ich nicht ausfindig machen kann.

 

PS: Falls jemand n' Raspi verkauft. Sagt mir Bescheid :-)

Edited by coincierge
Link to comment
Share on other sites

Puh, der Intel NUC zieht 10x mehr Strom als ein Raspi 4B. Hast du mal mit dem Raspberry Pi Imager einfach mal "Raspberry Pi OS", die Desktop-Version geflasht und mit der angeschlossenen SSD ausprobiert? Kann natürlich sein, daß Irgendwas nicht stimmt.

Falls du in einer Großstadt wohnen solltest, schau' doch mal, ob's nicht eine Maker-Werkstatt oder 'nen Linux-Club/Verein gibt. Da gibt's bestimmt RPi-Experten, die deiner Hardware auf den Zahn fühlen können.

Momentan ist die Liefersituation wirklich sehr bescheiden oder die Preise einfach nur abartig hoch, wenn einer überhaupt etwas liefern kann.

Edited by Cricktor
  • Like 1
Link to comment
Share on other sites

vor 3 Minuten schrieb Cricktor:

Hast du mal mit dem Raspberry Pi Imager einfach mal "Raspberry Pi OS", die Desktop-Version geflasht und mit der angeschlossenen SSD ausprobiert?

Genau - Umbrel hat ein Problem mit USB-Ports.

Einfach zweite SD-Karte mal bespielen und testen.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.