Jump to content

nVidia RT3070 ETH OC in Ubuntu20.04: nvidia-settings -a GPUGraphicsClockOffset/GPUMemoryTransferRateOffset not working


Konny123

Recommended Posts

Sorry I am a new Linux and nVidia user for ETH mining but hopefully someone can help me.

I am using:
    Ubuntu 20.04
    2 GPUs RTX 3070
    Asus B250 Mining Expert

I have installed all SW needed on a new Ubunt 20.04 like this:
    sudo -i
    apt install nvidia-driver-460
    nvidia-xconfig -a --cool-bits=28
    REBOOT

I checked my /etc/X11/xorg.conf file and coolbits = 28 was written in all 3 GPUs -> OK.
I tested nvidia-smi Undervoltage / Powerlimit (pl) for all GPUs:
nvidia-smi -pl 120
and it works also -> when mining with t-rex power limit is seen --> OK.

Wenn I go into "NVIDIA X SETTINGS"-APP I also can change manualy under each GPU PowerMizer the values for
    Graphics Clock Offset
    Memory Transfer Rate Offset
and after pressing ENTER the value becomes active -> when mining with t-rex Hash-Rate goes up --> OK.

BUT:
Overclocking is not running with this cmds from Terminal even the promt answer is "Attribute ... assingend":

nvidia-settings -a GPUGraphicsClockOffset[3]=-500
Attribute 'GPUGraphicsClockOffset' (katzminer-desktop:0.0) assigned to value -500.
Attribute 'GPUGraphicsClockOffset' (katzminer-desktop:0.1) assigned to value -500.
Attribute 'GPUGraphicsClockOffset' (katzminer-desktop:0[gpu:0]) assigned to value -500.
Attribute 'GPUGraphicsClockOffset' (katzminer-desktop:0[gpu:1]) assigned to value -500.

nvidia-settings -a GPUMemoryTransferRateOffset[3]=2200
Attribute 'GPUMemoryTransferRateOffset' (katzminer-desktop:0.0) assigned to value 2200.
Attribute 'GPUMemoryTransferRateOffset' (katzminer-desktop:0.1) assigned to value 2200.
Attribute 'GPUMemoryTransferRateOffset' (katzminer-desktop:0[gpu:0]) assigned to value 2200.
Attribute 'GPUMemoryTransferRateOffset' (katzminer-desktop:0[gpu:1]) assigned to value 2200.

Also when I check in "NVIDIA X SETTINGS"-APP under each GPU PowerMizer the value for GraphicsClockOffset und MemoryTransferRateOffset is still values 0 ...

What do I make wrong ??

All the helps is much appreciated.
Thank you in advanced!

Konny

Link to comment
Share on other sites

added:

I tested nvidia-serttings fan for all GPUs like this:
nvidia-settings -a [gpu:0]/GPUFanControlState=1
nvidia-settings -a [fan:0]/GPUTargetFanSpeed=50
and it works also -> fans are at once running faster

 

Questions:

I also tried for each GPU without success:
nvidia-setttings -c :0 -a '[gpu:0]/GPUMemoryTransferRateOffset[3]=2200'
nvidia-settings -c :0 -a '[gpu:0]/GPUGraphicsClockOffset[3]=-500'
Do i need to use "sudo" before "nvidia-settings" ?

Or do I need to set persistency mode before like this:
nvidia-smi --persistence-mode=1
?

Do I have to set PowerMizer-Mode also ?

Is my installation of nvidia-driver correct ? Because in forum I also saw that users intsall nvidia-driver in other way like this:
$> sudo add-apt-repository ppa:graphics-drivers/ppa
$> sudo apt update
$> sudo apt install ubuntu-drivers-common
$> sudo apt install nvidia-driver-460
$> sudo reboot

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.