Jump to content

Nur 30MH/s mit AMD Radeon RX 6800 XT (PowerColor / Red Devil)


gotroot

Recommended Posts

Guten Morgen,

ich habe mir eine RX 6800 XT für 1407€ zum Minen gekauft. Fast 99% aller Funde an Informationen zu der Karte sagen, dass sich damit 64 +/- MH/s bei Ethereum erreichen lassen. Ich hab nun eine Workstation mit i3 CPU, 16GB-RAM und SATA Platte sowie Windows 7 x64 Prof mit dieser Karte laufen. Als Treiber hab ich den aktuellsten vom Hersteller genommen. Das PSU ist ein fast neues "be quiet!" mit 500 Watt.

Zur Info vorab, Temperatur und Stromkosten sind kein Thema. Die Box ist klimatisiert und Strom ist ... nennen wir es eine Flatrate.

Ich komme mit der Karte beim Besten Willen aber nicht über 30 MH/s.

Screenshot nanominer auf ETH über nanopool(dot)org: https://prnt.sc/133zbzx

In der Radeon Software hab ich bereits alle möglichen Konfigurationen durchgespielt aber höher als 31 MH/s bin ich bislang nie gekommen. Das macht mich jetzt natürlich in Anbetracht dessen, dass die Karte doch ordentlich Power hat und dementsprechend kostspielig war, etwas traurig ^^

Jemand eine Idee was ich machen soll?

Danke und Grüße vorab!

Edited by gotroot
Link to comment
Share on other sites

Mit Windows 7 ist das so, damit wird das nix. Du musst Windows 10 nehmen.

Alle Updates solltest du deaktivieren. Das kann man z.b. mit "Windows 10 do not spy" machen. Der Defender versucht dann immer die Miner zu deaktivieren, manchmal verschiebt er sie in Quarantäne. Da musste die dann wieder aus der Quarantäne ziehen und die als Ausnahme markieren das die gestartet werden dürfen.

Kann ich jetzt grad im Detail nicht beschreiben, ich nutz Linux, Windows eher selten, eher so zum ausprobieren.

Den Adrenalin-Treiber musst du warscheinlich in einer älteren Version nehmen, 20.11.xx oder niedriger wars glaub ich, sonst gibts Probleme das die Miner die Karten nicht erkennen weil das OpenCL nicht richtig funktioniert.

  • Love it 1
Link to comment
Share on other sites

Super und vielen Dank @battlecore

Win10 installiert, Update-Service, Defender und Co. deaktiviert. Da die Kiste eh hinter seiner eigenen FW und VLAN läuft ist kein Software AV/IDS/IPS nötig.

Rennt jetzt ohne Optimierungen / Overclock mit 59MH/s 🙂

 

 

  • Like 1
Link to comment
Share on other sites

@battlecore, also das mit dem Windows 10 taugt mir nicht. System läuft instabil und hab keine Lust da jetzt Stunden zu investieren da Windows für so einen Job eh fehl am Platz ist.

Hab jetzt ein Ubuntu LTS und die amdgpu-pro-21.10-*-ubuntu-20.04 installiert aber der Miner (nanominer) erkennt leider keine GPU. Neustart ist schon erledigt.

Vielleicht spontan eine Idee was da los ist?

Link to comment
Share on other sites

vor 41 Minuten schrieb gotroot:

@battlecore, also das mit dem Windows 10 taugt mir nicht. System läuft instabil und hab keine Lust da jetzt Stunden zu investieren da Windows für so einen Job eh fehl am Platz ist.

Hab jetzt ein Ubuntu LTS und die amdgpu-pro-21.10-*-ubuntu-20.04 installiert aber der Miner (nanominer) erkennt leider keine GPU. Neustart ist schon erledigt.

Vielleicht spontan eine Idee was da los ist?

Ja. Du musst amdgpu pro 20.30 nehmen.

Der 21.10 geht mit den Minern nicht. Dann wird das opencl nicht richtig installiert.

Öffne den Ordner /sys/bin (glaub ich). Da ist die uninstalldatei drin und die rufst im Terminal dann auf. Kennste ne? Rechtsklick in das Fenster und "im Terminal öffnen".

Danach kannste den Treiber 20.30 installieren.

Vor der installation kannste mal folgendes in einem Terminal machen:

sudo dpkg --configure -a

Und dann:

sudo apt install libnuma-dev libncurses5

Danach ganz normal den Treiber installieren.

./amdgpu-pro-install -y --opencl=pal,legacy

 

Mit clinfo kannst du prüfen ob alles korrekt ist.

sudo apt-get install clinfo

Dann kannst du es mit "clinfo" im Terminal aufrufen. Ganz oben sollte "Platforms    1"  stehen. Und etwas darunter bei Devices sollte die Anzahl deiner Grafikkarten stehen. Also z.b. "Devices   3".

Ganz unten stehen auch die Bezeichnungen der Grafikkarten. Also in diesem Beispiel z.b. gfx900 gfx900 gfx906.

Edited by battlecore
  • Like 1
Link to comment
Share on other sites

vor 2 Stunden schrieb battlecore:

Danach ganz normal den Treiber installieren.

./amdgpu-pro-install -y --opencl=pal,legacy

Hab die Box neu installiert, trotzdem hat er irgendwie kein Bock drauf...

OS: ubuntu-20.04.2.0-desktop-amd64.iso
Treiber: https://drivers.amd.com/drivers/linux/amdgpu-pro-20.40-1147286-ubuntu-20.04.tar.xz

@battlecore andere Version als empfohlen .. habs aus dem Tut hier: https://www.blog.albertbling.com/posts/how-to-mine-ethereum-on-linux/

Fehler nach ...

CMD: lupo@wks1-lupo:~/amdgpu-pro-20.40-1147286-ubuntu-20.04$ ./amdgpu-pro-install -y --opencl=pal,legacy

amdgpu-dkms (1:5.6.14.224-1147286) wird eingerichtet ...
Loading new amdgpu-5.6.14.224-1147286 DKMS files...
Building for 5.8.0-53-generic
Building for architecture x86_64
Building initial module for 5.8.0-53-generic
Error! Bad return status for module build on kernel: 5.8.0-53-generic (x86_64)
Consult /var/lib/dkms/amdgpu/5.6.14.224-1147286/build/make.log for more information.
dpkg: Fehler beim Bearbeiten des Paketes amdgpu-dkms (--configure):
 »installiertes amdgpu-dkms-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 10 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von amdgpu:
 amdgpu hängt ab von amdgpu-dkms (= 1:5.6.14.224-1147286); aber:
  Paket amdgpu-dkms ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes amdgpu (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
libegl1-amdgpu-mesa-drivers:i386 (1:20.1.5-1147286) wird eingerichtet ...
Es wurde kein Apport-Bericht verfasst, da die Fehlermeldung darauf hindeutet, dass dies lediglich ein Folgefehler eines vorherigen Problems ist.
                                                                                                                                                g++-9 (9.3.0-17ubuntu1~20.04) wird eingerichtet ...
g++ (4:9.3.0-1ubuntu2) wird eingerichtet ...
update-alternatives: /usr/bin/g++ wird verwendet, um /usr/bin/c++ (c++) im automatischen Modus bereitzustellen
build-essential (12.8ubuntu1.1) wird eingerichtet ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von amdgpu-pro:
 amdgpu-pro hängt ab von amdgpu (= 20.40-1147286); aber:
  Paket amdgpu ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes amdgpu-pro (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Es wurde kein Apport-Bericht verfasst, da die Fehlermeldung darauf hindeutet, dass dies lediglich ein Folgefehler eines vorherigen Problems ist.
                                                                                                                                                Es wurde kein Apport-Bericht verfasst, da das Limit MaxRepo
rts bereits erreicht ist.
                         dpkg: Abhängigkeitsprobleme verhindern Konfiguration von amdgpu-pro-lib32:
 amdgpu-pro-lib32 hängt ab von amdgpu (= 20.40-1147286) | amdgpu-hwe (= 20.40-1147286); aber:
  Paket amdgpu ist noch nicht konfiguriert.
  Paket amdgpu-hwe ist nicht installiert.
 amdgpu-pro-lib32 hängt ab von amdgpu-pro (= 20.40-1147286) | amdgpu-pro-hwe (= 20.40-1147286); aber:
  Paket amdgpu-pro ist noch nicht konfiguriert.
  Paket amdgpu-pro-hwe ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes amdgpu-pro-lib32 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
amdgpu-lib32 (20.40-1147286) wird eingerichtet ...
Trigger für man-db (2.9.1-1) werden verarbeitet ...
Trigger für libc-bin (2.31-0ubuntu9.2) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 amdgpu-dkms
 amdgpu
 amdgpu-pro
 amdgpu-pro-lib32
E: Sub-process /usr/bin/dpkg returned an error code (1)
lupo@wks1-lupo:~/amdgpu-pro-20.40-1147286-ubuntu-20.04$ 

 

Edited by gotroot
Link to comment
Share on other sites

@gotroot ja die Meldungen sind normal. Die AMD-Treiber sind nicht so toll.

Prüf mit clinfo, wie beschrieben.

Bei mir und vielen anderen hats mit Treiber 20.40 nicht funktioniert. Weil der eine andere Version vom Linuxkernel voraussetzt.

Du solltest auch die Ubuntuupdates ausschalten. Auch während der Installation sollten keine Updates installiert werden.

 

Link to comment
Share on other sites

"clinfo" hab ich gecheckt. Keine Geräte erkannt.

Treiber https://drivers.amd.com/drivers/linux/amdgpu-pro-20.30-1109583-ubuntu-20.04.tar.xz hab ich gecheckt, gleiche Output.

Aus Gewohnheit hab ich das OS nach der Installation mit den aktuellsten Updates/Patches versorgt, bin aber grad dabei die Reinstall einzurichten.

...aber nein auch das frische OS ohne Updates mag nicht. Geh gleich auf der Autobahn Lichter fangen 🥴

./amdgpu-pro-install -y --opencl=pal,legacy

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 amdgpu-dkms : Hängt ab von: libc-dev oder
                              libc6-dev soll aber nicht installiert werden
 amdgpu-lib32 : Hängt ab von: libdrm2-amdgpu:i386 (= 1:2.4.100-1109583)
                Hängt ab von: libdrm-amdgpu-amdgpu1:i386 (= 1:2.4.100-1109583)
                Hängt ab von: libllvm10.0-amdgpu:i386 (= 1:10.0-1109583)
                Hängt ab von: libxatracker2-amdgpu:i386 (= 1:20.1.0-1109583)
                Hängt ab von: libgbm1-amdgpu:i386 (= 1:20.1.0-1109583)
                Hängt ab von: libegl1-amdgpu-mesa:i386 (= 1:20.1.0-1109583)
                Hängt ab von: libegl1-amdgpu-mesa-drivers:i386 (= 1:20.1.0-1109583)
                Hängt ab von: libgles1-amdgpu-mesa:i386 (= 1:20.1.0-1109583)
                Hängt ab von: libgles2-amdgpu-mesa:i386 (= 1:20.1.0-1109583)
                Hängt ab von: libglapi-amdgpu-mesa:i386 (= 1:20.1.0-1109583)
                Hängt ab von: libgl1-amdgpu-mesa-glx:i386 (= 1:20.1.0-1109583)
                Hängt ab von: libgl1-amdgpu-mesa-dri:i386 (= 1:20.1.0-1109583)
                Hängt ab von: libosmesa6-amdgpu:i386 (= 1:20.1.0-1109583)
                Hängt ab von: mesa-amdgpu-va-drivers:i386 (= 1:20.1.0-1109583)
                Hängt ab von: mesa-amdgpu-vdpau-drivers:i386 (= 1:20.1.0-1109583)
 amdgpu-pro-lib32 : Hängt ab von: libgl1-amdgpu-pro-glx:i386 (= 20.30-1109583)
                    Hängt ab von: libegl1-amdgpu-pro:i386 (= 20.30-1109583)
                    Hängt ab von: libgles2-amdgpu-pro:i386 (= 20.30-1109583)
                    Hängt ab von: libglapi1-amdgpu-pro:i386 (= 20.30-1109583)
                    Hängt ab von: libgl1-amdgpu-pro-dri:i386 (= 20.30-1109583)
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Schaut mir fast so aus als wolle er eine 386er Umgebung

Edited by gotroot
  • Haha 1
Link to comment
Share on other sites

Aaach mist ich hab was wichtiges vergessen.

Wenn du den Treiber deinstallierst, dann auf keinen Fall einen Neustart machen. Sonst haste schwarzen Bildschirm.

Man muss direkt nach der Deinstallation den Treiber erneut installieren / neuen Treiber installieren.

 

Hast du das gemacht?

vor 6 Stunden schrieb battlecore:

sudo apt install libnuma-dev libncurses5

Tjoa, weiss auch nicht. Also bei mir funktioniert das super auf diese Weise.

Das die Treiberinstallation einige Fehlermeldungen gibt ist halt so, die Treiber sind halt echt total bescheiden. Auch bei Windows.

Mach jetzt mal folgendes:

sudo apt update --fix-missing

dann

sudo dpkg --configure -a

dann

sudo apt-get install -f

 

 

 

 

Edited by battlecore
  • Like 1
Link to comment
Share on other sites

vor 6 Minuten schrieb battlecore:

Man muss direkt nach der Deinstallation den Treiber erneut installieren / neuen Treiber installieren.

Roger! Wurde auch so erledigt.

vor 6 Minuten schrieb battlecore:

sudo apt install libnuma-dev libncurses5

Daraus resultiert eigentlich der Fehler hier

root@wks1-lupo:# sudo apt install libnuma-dev libncurses5
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libnuma-dev : Hängt ab von: libc6-dev soll aber nicht installiert werden oder
                              libc-dev
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
root@wks1-lupo:# 

  

vor 6 Minuten schrieb battlecore:

sudo apt update --fix-missing

Alle Pakete sind aktuell.

vor 7 Minuten schrieb battlecore:

sudo dpkg --configure -a

nix neues

 

vor 7 Minuten schrieb battlecore:

sudo apt-get install -f

auch nix neues

Edited by gotroot
Link to comment
Share on other sites

Ja ok das ist ein Problem.

Was noch machbar ist wäre es die defekten Pakete zu entfernen und aufzuräumen.

sudo dpkg --configure -a

sudo apt-get autoremove

sudo apt clean

sudo apt update --fix-missing

sudo apt install -f

sudo apt upgrade

sudo apt dist-upgrade

 

 

 

  • Like 1
Link to comment
Share on other sites

vor 21 Minuten schrieb battlecore:

sudo apt-get install libc6-dev libc-dev libnuma-dev

output

root@wks1-lupo:/home/lupo# sudo apt-get install libc6-dev libc-dev libnuma-dev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Hinweis: »libc6-dev« wird an Stelle von »libc-dev« gewählt.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libc6-dev : Hängt ab von: libc6 (= 2.31-0ubuntu9) aber 2.31-0ubuntu9.2 soll installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

und auch bei allem anderen, nichts zu tun. 🙈

root@wks1-lupo:/home/lupo# sudo dpkg --configure -a
root@wks1-lupo:/home/lupo# sudo apt-get autoremove
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
root@wks1-lupo:/home/lupo# sudo apt clean
root@wks1-lupo:/home/lupo# sudo apt update --fix-missing
Holen:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Ign:1 file:/var/opt/amdgpu-pro-local ./ InRelease
Holen:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]
Holen:2 file:/var/opt/amdgpu-pro-local ./ Release [816 B]
Holen:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg
Ign:3 file:/var/opt/amdgpu-pro-local ./ Release.gpg
OK:4 http://deb.anydesk.com all InRelease
OK:5 http://de.archive.ubuntu.com/ubuntu focal InRelease                                                    
OK:6 http://security.ubuntu.com/ubuntu focal-security InRelease                                             
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.
root@wks1-lupo:/home/lupo# sudo apt install -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
root@wks1-lupo:/home/lupo# sudo apt upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
root@wks1-lupo:/home/lupo# sudo apt dist-upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
root@wks1-lupo:/home/lupo# 

 

Werde es jetzt mal mit einem 18.04er Ubuntu probieren.

Edited by gotroot
Link to comment
Share on other sites

Naja, ist doch super. Alles ist in Ordnung. Es brauchen keine Pakete aktualisiert oder neu installiert oder entfernt werden...

Läuft doch 😁

sudo usermod -a -G render lupo

sudo usermod -a -G video lupo

lupo ist dein Anmeldename, ohne das @ -Zeichen und alles. Klein und Grossschreibung beachten.

In der Annahme das dein Treiber dennoch korrekt installiert ist, aber du nicht zu den beiden genannten Groups  render und video hinzugefügt ist.

Prüfe dann mit clinfo ob sich was getan hat.

 

Edited by battlecore
Link to comment
Share on other sites

Wenn clinfo anzeigt das die Opencl-Platfform da ist, also "platforms 1", dann ist der Treiber korrekt da.

Wenn clinfo weiter anzeigt "devices 0" dann ist es eher ein Hardwareproblem. Da ist der Fehler oft das die Grafikkarte im falschen Slot steckt. Denn jedes Mainboard initialisiert eine Grafikkarte beim Start in einem bestimmten Slot.

Das ist in der Regel Slot 1, der Slot der direkt neben der CPU ist bzw. der CPU am nächsten.

Steck die Grafikkarte da mal rein.

Wird hingegen der Treiber nicht wenigstens 1 mal richtig initialisiert, dann hat er auch in Zukunft ein Problem. Da hilft es die Grafikkarte mal in die anderen Slots zu stecken.

 

Wenn du sie nativ im Slot hast, also direkt die Grafikkarte da drin, ohne Riser, dann hilft das manchmal.

Wenn du Riser hast, dann probier mal einen anderen Typ Riser aus. Riser sind Problemteil nr.1 und man kann oft gar nicht nachvollziehen wieso die einen laufen und die anderen nicht.

Ich hab z.b. eine Radeon VII die in einem der Rigs nur mit einem einzigen Riser läuft. Und ich hab auch nur den einen diesen Typs. Wenn der mal Hopps geht dann steh ich doof da.

Leider bekommt man auch nicht immer die Riser geliefert die man bestellt. Das ist offenbar so nach Zufallsprinzip bei manchen Händlern.

Link to comment
Share on other sites

Also da das mit dem Linux gestern nicht wollte, hab ichs nochmal mit Windows 10 probiert. Diesmal

Win10 Prof ohne Netzwerk installiert, nach der Installation den Windows-Update Service gestoppt und deaktiviert,
die neuesten Treiber installiert (non-whql-radeon-software-adrenalin-2020-21.5.2-win10-64bit-may17.exe),
Adrenalin Grundkonfiguriert:

https://www.elefacts.de/test/6x_amd_radeon_rx_6700_xt_gpus_als_ethereum_mining_rig_2.jpg

nanominer gestartet und schwupp läuft das Ding auf Anhieb mit 63MH/s bei 167 Watt, 59°C Kerntemperatur und 56% Lüftung.

@battlecore zu deinem letzten Post oben, ich hab nur einen PCI-E Slot und die Karte steckt direkt auf dem Mainboard. Jetzt wo das läuft bin ich mit dem aktuellen Setup zufrieden. Wenn da noch mehr Karten kommen sollten schau ich mir das Thema Linux nochmal genauer an.

 

Jetzt mal schauen wie wir die MH/s vielleicht noch etwas höher bekomme :)

Edited by gotroot
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.