Jump to content

2x RX580 Rig, eine davon liefert nur 7mh/s


alfredjodocus

Recommended Posts

Hallo liebe Mining-Freunde,

ich habe ein kleines Problem mit meinem Setup, ich verwende 2 RX580 8GB zum minen von Ethereum. Die eine habe ich auf ca. 30mh/s, die andere läuft nur mit 7mh/s.
Hier meine verwendeten Komponenten:
CPU i5-3570
16GB RAM
Mainboard MSI z77a-g41
Netzteil Hydro PRO 500W
1x AMD RX580 8GB Armor OC
1x AMD RX580 8BG XFX (memorychips beide Samsung)
Verwende 2miners/ethash und habe nicehash ausprobiert, bei beiden das selbe.

Ich weiß dass das Netzteil mit 500W etwas schwach ist, aber beide GPUs zusammen ziehen nur ca. 200W und beim minen mache ich nebenher nichts anderes. Kann hier schon das Problem liegen?

Die erste GPU habe ich am PCI_E2 (x16, PCI 3.0) angeschlossen, die zweite am PCI_E4 (x16, PCI 2.0) angeschlossen.

Die AMD Treiber habe ich aktualisiert, als Einstellungen overclocking und undervolting, und auf Berechnung anstatt gaming gestellt.

Energiesparoptionen von Windows sind ausgeschaltet. Habe auch die Steckplätze der Karten mal umgedreht, ist trotzdem noch das selbe.

Wo vermutet ihr denn das Problem, dass die zweite Karte so eine niedrige hashrate hat?

Hoffe ich habe alle wichtigen Infos hier reingeschrieben und ihr könnt mir helfen. Würde mich echt freuen :)

Danke und Gruß
Alfred J. Quak :D

 


 

Link to comment
Share on other sites

Das 7MH-Problem ist bekannt. Bzw. Karten die so zwischen 7 und 11Mh liefern. Wird meistens verursacht durch aufeinanderfolgende PCIe-Portadressen.

Also z.b. Karte 1 PCIe 11, Karte 2 PCIe 12.

Die Miner zeigen das eigentlich alle an beim start. Die Portadresse steht dann direkt hinter der jeweils aufgezählten Karte.

Du musst eine der Karten in einen anderen Port stecken, wenn zwischen den Karten ein Steckplatz frei bleibt dann haben die in der Regel auch bei den Portadressen eine dazwischen frei. Also dann z.b. PCIe 11 und die andere PCIe 13. Aber da musst du mehrere Slots mal durchprobieren.

Der lange PCIe-Slot der der CPU am nächsten ist kannst du auch benutzen, das müssen nicht unbedingt alles die kurzen Slots sein. Die Riser funktionieren auch in den langen Slots.

Edited by battlecore
Link to comment
Share on other sites

Hi und vielen Dank für deine Antwort! :)
Als Adressen steht beim Start folgendes:

GPU0: 1:0
GPU1: 6:0

Ich habe die beiden Karten in den x16 also den großen Slots und verwende keinen Riser, ist das der Fehler?
Ich denke PCIe1 könnte ich z.B. mit Riser verwenden.

Oder könnte der Fehler noch wo anders liegen?

Danke und schönes Wochenende

Edited by alfredjodocus
Link to comment
Share on other sites

Am 28.8.2021 um 15:13 schrieb alfredjodocus:

Hi und vielen Dank für deine Antwort! :)
Als Adressen steht beim Start folgendes:

GPU0: 1:0
GPU1: 6:0

Ich habe die beiden Karten in den x16 also den großen Slots und verwende keinen Riser, ist das der Fehler?
Ich denke PCIe1 könnte ich z.B. mit Riser verwenden.

Oder könnte der Fehler noch wo anders liegen?

Danke und schönes Wochenende

Die Riser kannst du in lange oder kurze Slots stecken, das ist egal.

Hat die Karte von Anfang an nur 7MH oder hat die erst mehr und geht dann nach 5 oder 10 Minuten runter auf 7MH?

Wenn die Karten nah zusammen sind dann saugt eine davon ja durch die Lüfter immer die warme Luft von der Rückseite der anderen Karte an. Dann wird sie heiss und taktet sich automatisch runter.

Im Treiber solltest du die Standardeinstellungen laden und dann nur das Powerlimit/Powertarget/Leistungsgrenze (das heisst bei manchen Versionen anders) runterstellen auf wenigstens -20. Das begrenzt den Stromverbrauch der Karte indem es Taktfrequenz und Spannung automatisch regelt. Das funktioniert besser als eine manuelle Anpassung.

Zusätzlich solltest du die Lüfter hochdrehen lassen. Das ist auch im Treiber einstellbar, als Kurve die man verändern kann. Auf weniger als 70 Prozent sollten die Lüfter nie sein.

Beide Einstellungen sind bei den Tuningoptionen zu finden, du musdt das umstellen auf manuelle Einstellungen um da dranzukommen.

Link to comment
Share on other sites

Also wie gesagt ich verwende keine Riser....
Die eine Karte liefert von Anfang an nur ca. 7mh/s ...

An der Temperatur liegt es auch nicht, habe die Lüfter mal voll laufen lassen sodass die Karten auf unter 60Grad gelaufen sind, es hat sich aber nichts verändert.

Weiß leider echt nicht mehr weiter :(

Link to comment
Share on other sites

Am 26.8.2021 um 19:40 schrieb alfredjodocus:

Die AMD Treiber habe ich aktualisiert, als Einstellungen overclocking und undervolting, und auf Berechnung anstatt gaming gestellt.

Hast du ältere Treiber ausprobiert? Je neuer die Treiber sind umso eher gibt es Probleme. Ich hatte gestern zufällig noch mal Windows 10 ausprobiert, da musste ich auf einen AMD-Treiber von 2019 Version 19.8.2 zurückgehen bis alles funktionierte.

Aber da musste ich auch nach dem runterladen des Treibers die internetverbindung trennen und dann erst den Treiber installieren. Und dann auch im Treiber die Updatefunktion deaktivieren. Beim ersten Versuch hat der sofort nach der Installation den aktuellen Treiber runtergeladen und im Hintergrund installiert, nachm nächsten Neustart war plötzlich der neue Treiber drauf.

Link to comment
Share on other sites

vor 9 Stunden schrieb battlecore:

Hast du ältere Treiber ausprobiert? Je neuer die Treiber sind umso eher gibt es Probleme. Ich hatte gestern zufällig noch mal Windows 10 ausprobiert, da musste ich auf einen AMD-Treiber von 2019 Version 19.8.2 zurückgehen bis alles funktionierte.

Aber da musste ich auch nach dem runterladen des Treibers die internetverbindung trennen und dann erst den Treiber installieren. Und dann auch im Treiber die Updatefunktion deaktivieren. Beim ersten Versuch hat der sofort nach der Installation den aktuellen Treiber runtergeladen und im Hintergrund installiert, nachm nächsten Neustart war plötzlich der neue Treiber drauf.

Battlecore du bist (m)ein Held!!! :D
Habe es so gemacht wie du gesagt hast und siehe da - insgesamt ca. 53mh/s! Sind zwar noch nicht die knapp 60 die ich wollte, aber der Rest ist nurnoch Feintuning!
Vielen lieben Dank an dich :)

Kann es mir nicht erklären, aber vermute vielleicht dass AMD nicht möchte dass man mit mehr als einer Grafikkarte mined, deswegen die geringere Hashrate?

Jedenfalls nochmal ein dickes Danke und einen schönen Abend an dich! :)

  • Like 1
Link to comment
Share on other sites

AMD hat zwischendurch ein anderes OpenCL verwendet das aktueller ist, aber nicht von allen Softwareherstellern genutzt wird. Daher sind da son paar Treiberversionen die so gesehn auch nicht zum minen taugen weil da das konventioneller OpenCL benutzt wird. Die Miner können auch nicht ständig diesen oft nur kurzlebigen Änderungen hinterherrennen.

Da muss man einfach öfter mal rumprobieren welcher Treiber gut funktioniert.

Das war aber früher noch viel schlimmer, die ersten 3D-Beschleuniger damals waren von einer Version zur nächsten plötzlich unbrauchbar, dann wieder ne Änderung und sie gingen wieder. Ich hab damals selbst Treiber zusammengeschraubt damit ich micht nicht immer auf die 9862304ste Änderung verlassen muss.

Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.