Jump to content

Kabelaffe84
 Share

Recommended Posts

Hallo, kennt sich jemand mit storj aus?

ich wollte jetzt von burstcoin auf storj umsteigen, aber irgendwie bekomm ich das mit der Portweiterleitung nicht hin.

aktuell sieht es so aus:

router Fritzbox 7490( am Internet) per WLAN verbunden mit einer Fritzbox 3272 von da aus auf einen 8 Fach switch per LAN Kabel.

an der Fritzbox 3272 hängen aktuell 10 rigs 7 am Switch und 3 direkt an der 3272 per kabel.

an der Hauptbox habe ich nun für jedes rig die Ports 4000-4010 für udp und tcp freigegeben + upnp status automatisch weiterleiten.

dann habe ich mich bei No-ip angemeldet und diese Daten in der hauptfritzbox bei dyndns eingetragen.

nach den portfreigaben hat die Fritzbox auch die Ports 62244-62266 für udp und tcp automatisch freigeben, warum weis ich allerdings dings nicht.

wenn ich jetzt das Programm storj Share öffne sind meine porte stehts schwarz, die sollten aber grün sein.

die Ports habe ich dann im Internet getestet bei den 4000-4010 bekomme ich die Meldung Port is closed.

und bei den 62244-62266 bekomm ich die Meldung Port is Open,

aber vom Programm bekomm ich bei den Ports die Meldung Connection timed out.

in der Firewall von windows habe ich per eingehende Verbindung Regel die Ports oben freigegeben.

 

was mach ich falsch ?

Link to comment
Share on other sites

Vielleicht hilft das (aus der Fritz!Box Wissensdatenbank):

Wenn ein Portbereich freigegeben werden soll:
Tragen Sie unter "Port an Gerät" die erste und unter "bis Port" die letzte Portnummer ein, auf der der Serverdienst bzw. die Anwendung Verbindungen entgegen nimmt.
Tragen Sie unter "Port extern gewünscht (IPv4)" die erste Portnummer ein, auf der der Serverdienst bzw. die Anwendung Verbindungen entgegen nimmt.

 

Lohnt sich das mit dem Festplattenmining, bzw. wie sind deine Erfahrungen mit Burstcoin ?

Link to comment
Share on other sites

ich hab mir halt damals gedacht, wozu die 4 -6 sata plätze am mining rig ungenutzt lassen also hab ich da 8tb Festplatten dran,

sprich gesamt habe ich so an die 130tb.

also so um die Jahreswende gab es pro 1000 burst knapp 30$ jetzt gibt es nur noch 19$ deswegen wollt ich mal storj ausprobieren.

ob es sich lohnt ist halt jedem selbst überlassen, ich sag mal so ich meine Festplatten damal für 75€ je stück bekommen, die kosten habe ich mittlerweile wieder raus, nur bei 19$ je 1000 burst lohnt sich die Anschaffung eher nicht. weil das plotten dauert ewig gerade in der grösse, ich habe damals knapp 5 tage gebraucht.

aber wie gesagt man macht damit zwar nicht die mega kohle aber dafür das es einfach so mitläuft ist es ok.

 

Ich wollte jetzt storj ausprobieren weil es sich defentiv mehr lohnt. wenn mir das auch nicht zusagt benutz ich die für Siacoin 

  • Thanks 1
Link to comment
Share on other sites

Was meinst du mit Nat? Ich habe kein Plan von Netzwerken, ich habe einfach nur in der Fritzbox die Ports freigegeben und ein Kreuz gemacht das der pc Ports selbständig frei geben darf, bei einem rig läuft es jetzt komischerweise da ist es auch grün Port 57939 und er ist von tcp auf upnp gesprungen. vorher schwarz ?

alle anderen egal welchen Port ich einstelle springen automatisch in Port 40xx mit Tunnel dahinter in orange , aber laut hp ist Tunnel nicht gut.

schwarz heist das die Software nicht feststellen kann ob der Port offen ist und man das auf einer Homepage testen soll und da stand dann Port ist offen und man kann drauf zu greifen. Bevor es grün wurde und von tcp(schwarz) auf upnp ( grün) gesprungen ist

Link to comment
Share on other sites

NAT = Network Adress Translation. Ist nur nötig wenn tatsächlich eine Anwendung vom WAN in die DMZ/LAN soll.

Keine Ahnung wie du Stroj konfiguriert hast. Die port range  ist laut Stroj 4000-4003 TCP im folgenden Beispiel:

// Interface to bind RPC server, use 0.0.0.0 for all interfaces or if you
  // have a public address, use that, else leave 127.0.0.1 and Storj Share
  // will try to determine your address
  "rpcAddress": "Public IP address or DDNS hostname",
  // Port to bind for RPC server, make sure this is forwarded if behind a
  // NAT or firewall - otherwise Storj Share will try to punch out
  "rpcPort": 4000,
  // Enables NAT traversal strategies, first UPnP, then reverse HTTP tunnel
  // if that fails. Disable if you are public or using dynamic DNS
  "doNotTraverseNat": true,
  // Maximum number of tunnels to provide to the network
  // Tunnels help nodes with restrictive network configurations participate
  "maxTunnels": 3,
  // Maximum number of concurrent connections to allow
  "maxConnections": 150,
  // If providing tunnels, the starting and ending port range to open for
  // them
  "tunnelGatewayRange": {
    "min": 4001,
    "max": 4003
  },

Schlägt das fehl, dann wird ein Fallback über upnp versucht, ich rate aber davon ab.  Upnp bedeutet das sich jede Anwendung wie sie gerade lustig ist selbst Ports aufmachen kann.

In der Fritzbox musst du lediglich die Range von 4000-4003 TCP auf den LAN Port freigeben an dem der client angeschlossen ist.

Du hast aber zwei Router im Einsatz, ka ob die das selbe Netz/Subnetz haben und ka wie du das konfiguriert hast.

Sieht nach einem Routing Problem aus.

Edited by hagbase
Link to comment
Share on other sites

Hi, ja das beschreibt genau das was du schreibst,

der zweite Router ist als repeater eingerichtet.

wenb ich in cmd ipconfig eingebe ist der Gateway die haupt Fritzbox 

wie gesagt ich habe die Ports 4000-4010 freigegeben ( weil 10rig) und 1 davon ( das einzige was funktioniert) hat selbständig einen anderen Port geöffnet und zwar 57939

bei den 4000-4010 bekomm ich auf der Seite zum testen der Ports die Meldung das der Port zwar offen ist, aber manchmal Connection Times out oder Could recieve Host 

Link to comment
Share on other sites

ich hab mal nen paar bilder gemacht

die ersten drei zeigen es bei dem wo es geht und die letzten beiden, bei dem wo es nicht geht, bei dem letzten ändern der auch die port nummern automatisch in die 6xxxx obwohl ich auch 4000-4010 eingetragen habe, wenn ich zu dennen noch 4000-4010 eintrage sagt der mir das ist schon vorhanden

http://www.bilder-upload.eu/show.php?file=6f122b-1522949382.png

http://www.bilder-upload.eu/show.php?file=a53bfc-1522949387.png

http://www.bilder-upload.eu/show.php?file=c6703c-1522949397.png

http://www.bilder-upload.eu/show.php?file=11f4de-1522949412.png

http://www.bilder-upload.eu/show.php?file=9dff0e-1522949419.png

 

 

 

Edited by Kabelaffe84
Link to comment
Share on other sites

1 hour ago, Kabelaffe84 said:

ich hab mal nen paar bilder gemacht

die ersten drei zeigen es bei dem wo es geht und die letzten beiden, bei dem wo es nicht geht, bei dem letzten ändern der auch die port nummern automatisch in die 6xxxx obwohl ich auch 4000-4010 eingetragen habe, wenn ich zu dennen noch 4000-4010 eintrage sagt der mir das ist schon vorhanden

http://www.bilder-upload.eu/show.php?file=6f122b-1522949382.png

http://www.bilder-upload.eu/show.php?file=a53bfc-1522949387.png

http://www.bilder-upload.eu/show.php?file=c6703c-1522949397.png

http://www.bilder-upload.eu/show.php?file=11f4de-1522949412.png

http://www.bilder-upload.eu/show.php?file=9dff0e-1522949419.png

 

 

 

Also entweder statisch die Ports vergeben oder dynamisch, nicht beides gleichzeitig.

Wenn ich das richtig verstanden habe, hast du dyn dns eingerichtet,  da du keine Standleitung hast.  Ich verstehe nur nicht ganz warum du die Port Weiterleitung auf die dyn dns ip machst und nicht auf deine clients. Deine Fritzbox sollte dementsprechend unter der 85.212.128.112 erreichbar sein, deine Clients haben aber weiterhin intern die 192.168.178.0 ip range.

D.h. die Fritzbox muss wissen das alles was an der 85.212.128.112  an Port 4000 ankommt auf z.b. den client 192.168.178.59 Port 4000 geroutet/NAT werden muss.

 

Edited by hagbase
Link to comment
Share on other sites

85.212.128.112 das ist meine aktuelle ip fürs internet

das zweite rig hat jetzt auch automatisch auf upnp gestellt und ein port in der 10xxx geöffnet 

ich habe jetzt überall die 4000er rausgenommen bei dem port check ist  auch alles gut mit dem 10xxx

also aktuell läuft es, ich weis nur nicht warum es  nicht geht wenn ich einen festen port wie.zb den 4000er freigebe

 

da bekomme ich mittlerweile die Meldung: no route to host 

aber wie gesagt es läuft, ich hab zwar keine Ahnung wieso aber es tut,

mal kucken ob das mit der dyndns klappt wenn sich meine ip ändert

Link to comment
Share on other sites

1 hour ago, Kabelaffe84 said:

85.212.128.112 das ist meine aktuelle ip fürs internet

das zweite rig hat jetzt auch automatisch auf upnp gestellt und ein port in der 10xxx geöffnet 

ich habe jetzt überall die 4000er rausgenommen bei dem port check ist  auch alles gut mit dem 10xxx

also aktuell läuft es, ich weis nur nicht warum es  nicht geht wenn ich einen festen port wie.zb den 4000er freigebe

 

da bekomme ich mittlerweile die Meldung: no route to host 

aber wie gesagt es läuft, ich hab zwar keine Ahnung wieso aber es tut,

mal kucken ob das mit der dyndns klappt wenn sich meine ip ändert

Aso,  dennoch musst du den Port an den jeweiligen clients übersetzen.

Hast du beide Fritzboxen auf 192.68.178.0 laufen?

Link to comment
Share on other sites

On 6.4.2018 at 8:01 PM, Kabelaffe84 said:

hi jein ich habe 6 stück

192.168.178.1   ...6

 

aber an jedem pc ist der standartgateway zu der wo Internet dran ist also 192.168.178.1

192.168.178.0 ist nur der Netzwerkpool, geht von 0-255.

Dann sollte es normalerweise ausreichen auf dem gateway entsprechende Port Freigaben/NAT einzurichten.  D.h. upnp aus und dann jeweils  Port 4000-4003 TCP auf die 192.168.178.6 usw.  oder halt auf die jeweilige IP die der dhcp den clients zugewiesen hat. Kommt der dhcp auch von der ersten Fritzbox? Bzw. lässt sich die zweite Fritzbox einfach so als Repeater einrichten oder wie hast du das gelöst?

Ich hab z.B. Fritzbox/WAN->Hardware Firewall/Gateway->Switch/DHCP/LAN. Alles nach der Fritzbox ist eine andere IP Range/Subnetz etc.  und bin hinter einem doppel NAT.

 

Link to comment
Share on other sites

ich habe bei der Einrichtung der repeater im menü einfach auf repeater gestellt und den rest hat die Haupt fritzbox erledigt, also auch die ips selbst vergeben.

sprich egal wo ich bin wenn ich Fritz.box eingebe komme ich immer zur hauptbox, will ich zu den einzelnen geb ich die ip im browser ein oder klicke im menü der Haupt fritzbox auf die einzelne 

der dhcp ist an jedem pc oder Handy immer automatisch die hauptfritzbox

die range ist von 192.168.178.1 bis 200

lokaler dns Server ist 192.168.178.1

dhcp Server aktivieren ist angekreuzt

Gültigkeit 10 tage, weis aber nicht was das heist 

und da drunter steht

das Gast netz hat seinen eigenen bereich

192.168.179.1

Link to comment
Share on other sites

16 hours ago, Kabelaffe84 said:

ich habe bei der Einrichtung der repeater im menü einfach auf repeater gestellt und den rest hat die Haupt fritzbox erledigt, also auch die ips selbst vergeben.

sprich egal wo ich bin wenn ich Fritz.box eingebe komme ich immer zur hauptbox, will ich zu den einzelnen geb ich die ip im browser ein oder klicke im menü der Haupt fritzbox auf die einzelne 

der dhcp ist an jedem pc oder Handy immer automatisch die hauptfritzbox

die range ist von 192.168.178.1 bis 200

lokaler dns Server ist 192.168.178.1

dhcp Server aktivieren ist angekreuzt

Gültigkeit 10 tage, weis aber nicht was das heist 

und da drunter steht

das Gast netz hat seinen eigenen bereich

192.168.179.1

Dann sollte static NAT eigentlich einwandfrei funktionieren.

Die IP Adresse ist für 10 Tage gültig, danach wird sie neu vergeben.

Sofern deine RIGs nicht an Gastnetz angeschlossen sind, ist das erstmal zu vernachlässigen.

In einem deiner Screenshots sieht man z.B. das dein RIG 1050ti die ip 192.168.178.59 hat, genau drauf muss du das Portforwarding einrichten.

Ich hab mir dnydns bei der FB! nicht angeguckt, da man das ganze auch über myfritzbox lösen kann, so wähle ich mich z.B. per VPN in das Netzwerk ein, wo meine RIG steht.

Link to comment
Share on other sites

Genau die ip für die rigs sind statisch also sollten eigentlich nicht geändert werden, 

bei dyndns habe ich die Daten von No-ip eingetragen 

bei den Port Freigaben habe ich direkt das rig mit Namen aus der Liste der aktiven Netzwerkverbindungen gewählt also keine ip eingegeben oder so direkt auf den Namen geklickt 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.